Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: Maps not loading on https site Mixed Content

Maps not loading on https site Mixed Content 11 months 2 weeks ago #10258


  • Posts:26
  • Sven 's Avatar
  • Sven
  • Junior Member
  • OFFLINE
Hi Marco,

I have tried it and updated it to your version.

But unfortunately, the google maps are still not loading using https

Other maps are loading without a problem but not google maps - they only load when the site is shown in http

In the console I get the error:
Mixed Content: The page at 'https://www.proactionbikerent.com/bike-tracks' was loaded over HTTPS, but requested an insecure script 'http://maps.google.com/maps/api/jsXYZmyMyAPI'. This request has been blocked; the content must be served over HTTPS.
Last Edit: 11 months 2 weeks ago by Sven .
The administrator has disabled public write access.

Maps not loading on https site Mixed Content 11 months 2 weeks ago #10259


  • Posts:15 Thank you received: 1
  • Marco's Avatar
  • Marco
  • New Member
  • OFFLINE
Hi Sven,

This I think is part of the map configuration.

To fix this, you have to go into the administrator view, ander under 'components' -> 'jtrackgallery' -> 'maps' choose the google maps and then in the field 'External Script' change 'http:' to 'https:' (or try '//' instead, a total of there slashes: '///maps.google.com/' this will switch between http and https depending on context.

Let me know if this does not work for you.

Best regards,

Marco.
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Time to create page: 0.155 seconds